Frequently Asked Questions

Does Furcadia support older versions of Windows (Windows 98, 2000, XP)?

Currently, Furcadia officially requires at least Windows XP or better.

It is possible to run the latest client under Windows 2000 using a third-party solution. A community member has posted a step-by-step guide on the official forums at http://forums.furcadia.com. Note that this is not officially supported and we cannot provide help to users using this solution, or guarantee that future clients will continue to support Windows 2000.


 Last updated Sun, Dec 22 2013 12:00am

Please Wait!

Please wait... it will take a second!